Since the upstream jade package has been replaced by pug package and no longer maintained, we’ve decided to deprecate hexo-renderer-jade and replace it with hexo-renderer-pug.

To migrate, update your “package.json”,

-  "hexo-renderer-jade": "^0.4.1",
+ "hexo-rederer-pug": "^1.0.0",

and rename all *.jade files to *.pug.

hexo-renderer-jade 0.5.0

Breaking change

Dependencies

  • Update eslint requirement from ^5.9.0 to ^6.1.0 #28
  • Update mocha requirement from ^5.2.0 to ^6.0.1 #25
  • chore(package): delete jscs & update eslint-config-hexo to 3.0.0 #22
  • Update chai requirement from ^3.5.0 to ^4.2.0 #16

hexo-renderer-pug 1.0.0

The plugin was initially imported from hexo-renderer-jade repository up until this commit.

Following are the changes from the commit onwards

Breaking changes

  • drop Jade #2
  • rename to hexo-renderer-pug #1

Unit testing

  • ci(travis): add windows #4
{{uname}}

{{meta.replies}} 条回复
写下第一个评论!

-----------到底了-----------